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The CRISM Analysis Tool (CAT) 
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CRISM Analysis Toolkit (CAT) 

• The CRISM Analysis Toolkit (CAT) is a series of custom IDL 
procedures packaged as a plug-in to ENVI, a proprietary 
remote sensing software available through ITT Exelis. 

 
• To download and install the CAT, go to 
http://pds-geosciences.wustl.edu/missions/mro/crism.htm 

 
• You will need CAT Version 7.0 or better to utilize the 
MTRDRs and related data products. 
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CAT Distribution: File Locations 

•  IDL/ENVI procedures for CAT are found under: 
–   CAT_ENVI/save_add/CAT_programs 

• Calibration Data Records (CDR): 
– CAT_ENVI/aux_files/CDRs/ 

• Ancillary Data Records (ADR): 
– CAT_ENVI/aux_files/ADR/ 

• User manuals, CRISM SIS: 
– CAT_ENVI/aux_files 

• Default CAT output: 
– CAT_ENVI/out 

• CAT temporary file output: 
– CAT_ENVI/tmp 

•  Nominally CAT will clean up; files may be left in event of a crash; can 
be deleted after a session 
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CAT Setup 

• ENVI config file: 
– Need envi.cfg in CAT_ENVI 
– Can copy from one of the defaults, envi_win.cfg, envi_unix.cfg 

according to OS 
– Useful things it specifies: tmp file directory, default output directory, 

spectral library directory, default data directory (where it looks first 
to open files) 

• CAT config file: 
– CAT_ENVI/catconfigs/crismcat*.cfg 

•  Replace * with any text, or omit 
•  Can have multiple configs (multiple users, customized analysis, etc) 

– select at startup, reload during session if desired 
•  Not required 
•  PDS path, aux_files path, default volcano scan  
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CAT Startup 

• When CAT installed, ENVI starts with CAT menu added 
–  includes CAT version number 

• Additional CAT-specific items added under Help and 
Display/Tools menus 
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Open CRISM File 

 INPUT DATA: 
– CRISM PDS image file (*.img) 
– Corresponding PDS label (*.lbl) 

•  example:  frt000094f6_07_if166l_trr3.img              
  frt000094f6_07_if166l_trr3.lbl 

select input file in the ENVI 
dialog box that pops up 

Opens CRISM data in ENVI  
Available Bands and  
Display windows 
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Initial Display of image cube 

•  Any image cube is initially opened in 
ENVI in a cluster of 3 windows. 
•  Scroll (shows full spatial extent) 
•  Image (full spatial resolution) 
•  Zoom (4x resolution subset) 

•  Red box in the Scroll window shows 
location of Image window; red box in 
the Image window shows location of 
Zoom window. 

 
•  HINT: For CRISM images, it is usually 

helpful to maximize the Image window, 
after which the Scroll window is no 
longer needed. 

 Scroll 

Image 

Zoom 
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Plot parameters can be set from Spectral Profile 
window, Options > Plot_Parameters 
 
Colored vertical lines on spectral plot indicate RGB 
wavelength positions – can adjust, reload new 
combination in Image window. 

Displaying a Spectrum 

From the Image window menu, >Tools >Profiles >Z Profile (Spectrum) 
 

Z-profile 
extracted at 
Zoom 
window 
location. 
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Simple Image Processing and  
Summary Parameters 



11 

CAT: Convert PDS to CAT 

• CRISM PDS data for IR channel: 
– Spectrum stored long-to-short 
–  Last wavelength 65535 (CRISM invalid  

data code) 
• Convert Format: PDS to CAT  

– Reverses order of IR spectrum 
– Replaces the 65535 wavelength with 4.0 

microns 

Select input PDS file 
to convert here 
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CAT: File or Memory? 

Common CAT question: 
Output to file or memory? 

Select “File,” then select an output 
path and, usually, filename via the 
ENVI dialog: 

OR… 

Select “Memory” and 
computation proceeds, with 
output to Available Bands 
and Display window 
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CAT: Photometric & Atmospheric 
Corrections 

File selection dialog… 
then select corrections 

Then pick a volcano scan selection method… 
Then finally, select scaling 
wavelengths… 
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CAT: Photometric Correction  
Behind the Scenes 

 
 
Photometric Correction… 

First order correction to radiance for 
non-normal solar incidence:  

 Divide by cos(incidence angle)  

Get incidence angle at aeroid from DDR 
(ancillary data file) 
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CAT: Atmospheric Correction 
Behind the Scenes 

• Atmospheric Correction: Need to correct spectrum for 
absorption by CO2 
– Volcano scan: special observation viewing nadir on traverse 

across Olympus Mons 
– Estimate atmospheric transmission =  

       (base spectrum) / (summit spectrum) 
– Correct a scene spectrum by scaling the volcano scan 

transmission to match the scene at 2 wavelengths near the CO2 2-
micron band, then divide 
•  One near absorption peak, one in wings 
•  Adjusts for variable atmospheric optical depth- elevation, season… 
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CAT: Atmospheric Correction 
Behind the Scenes  

• Selecting scaling wavelengths: 2 options… 
–  McGuire 2-wavelength (2007/1980) [recommended] 

•  2007 nm near absorption peak 
•  1980 nm in wing, but close to 2007 to reduce systematic error in presence of broad 

mineralogical absorptions near 2 microns 
–  Pelkey 2-wavelength (2011/1899) 

•  Original wavelengths in CAT 
•  Closer match to OMEGA correction 
•  Occasional artifacts from scaling errors caused by mineralogical abosrption affecting 

2011 but not 1899 
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CAT: Data Filtering 1 

• CIRRUS 
–  Despiking (removing isolated noise spikes) 
–  Destriping (removing elevated detector columns) 
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CAT: Data Filtering 2 

• MRO CRISM Remove Stripes 
–  Alternate stripe removal algorithm 
–  Generally, CIRRUS destripe preferred 
–  But, Remove Stripes offers control over multiplicative vs. 

additive correction 



19 

Map Utilities 
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Summary Parameters 

Summary Parameters: algebraic measures of the strengths and positions of  
possible mineral absorptions, and measures of the spectral continuum.  
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Spectral Analysis Utilities 
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Summary Parameters 
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CAT: Data Filtering 3 

• Flatten Summary Products 
–  Removes banding along lines in summary product 

images 
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Working with Summary Parameters 

All parameters displayed in Available Bands List for summary 
parameter file.  
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Single Band Display 

•  Load the D2300 parameter: from Available Bands List, right click on 
D2300 and select Load Band to New Display 

•  Default Linear 2% stretch includes unrealistic 
parameter values less than zero 
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Apply Appropriate Stretch 

•  For most band depth and similar measures of absorption,  
•  Zero is the minimum realistic value 
•  The 99th percentile is typically a good maximum, although there is a 

empirically-determined “minimum maximum” that varies by 
parameter (e.g., 0.02 for D2300) 

•  From Image window, go to >Enhance >Interactive Stretching 

•  Type min and max values or slide  
dashed bars until at correct percentile 
values (will display along bottom) 

 
•  If needed, modify the histogram 

binning and range under >Options 
>Histogram Parameters 
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D2300 Display Comparison 

•  To apply color ramp, go to >Tools 
>Color Mapping > ENVI Color Tables 

Default Stretch 
(-0.007 to 0.021) 

Optimized Stretch, 
Grayscale 

(0.0 to 0.027) 

Optimized Stretch, 
Rainbow Color Ramp 

(0.0 to 0.027) 
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RGB Display and Stretch 

•  Load PHY from Available Bands List: 
>Select RGB Color >click on D2300, 
BD2210_2, and BD1900R2 to fill in 
RGB fields >New Display from drop-
down >Load RGB 

•  Optimize stretch of each band from 
Image window: >Enhance 
>Interactive Stretching 

 
PHY 
Browse 
Product 
Result: 

D2300 
Min: 0.002 

(distribution 
peak) 

Max: 0.025 (99th 
percentile) 

BD2210_2 
Min: 0.002 

(distribution 
peak) 

Max: 0.020 
(“minimum 
maximum”) 

BD1900R2 
Min: 0.002 

(distribution 
peak) 

Max: 0.047 (99th 
percentile) 
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Other Browse Products for 94F6 

FEM 
R: BD530_2 
G: SH600_2 
B: BDI1000VIS 
 

MAF 
R: OLINDEX3 
G: LCPINDEX2 
B: HCPINDEX2 

HYD 
R: SINDEX2 
G: BD2100_2 
B: BD1900_2 
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Browse Products 

From Table 3, Viviano-Beck, et al. (2014) 
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Linking Spectral and Summary Parameter 
Cubes 

•   From either Image window, >Tools >Link then one of  
•  >Link Displays for pixel-location based link (requires exactly same 

size images; allows blinking and transparency), -OR- 
•  >Geographic Link for map projected link (can be different spatial 

coverage or resolutions) 
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Spectral Analysis 
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Spectral Analysis Methods 

•  In general, there are 3 steps to spectral analysis: 
1.  Locate interesting material(s) 

- Summary parameters are a good start 
2.  Collect best possible spectra (scene “endmembers”) 

- Pixel average, Region of Interest (ROI), etc. 
3.  Interpret endmember spectra 

- E.g., comparison to laboratory mineral spectra 

• This is what ENVI is designed to do… 
–  There are many analysis tools/options available within the ENVI software 

environment.   
–  Not all of them work well with CRISM data. 
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Pixel-based Endmember Extraction (1/2) 

• As an example, let’s find an endmember spectrum for the 
D2300-bearing material in FRT000094F6. 

Emphasized Stretch 
(0.04 to 0.05) 

•  Load D2300 as single band 
and stretch to emphasize 
highest realistic D2300 values. 

•  Link D2300 with corrected 
TRDR spectral cube and PHY 
browse (optional, but useful) 

Spectral Cube 
RGB 

PHY Browse 

D2300 

link link 
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Pixel-based Endmember Extraction 
(2/2) 

•  From the linked spectral cube Image window, extract a Z-profile (Spectrum) 
•  In the spectral plot window 

–  Go to >Edit >Plot Parameters to adjust y-axis (65535 values skew the range)  
–  Right click anywhere to view Plot Key and set Z-profile Avg Window to 3x3 pixels 
–  Preserve this spectrum for later use under >Options >New Window: with Plots… 

Spectral Cube 
RGB 
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ROI-based Endmember Extraction (1/3) 

•  Create a Region of Interest (ROI) from the 
highest D2300 values throughout the scene 

•  In the spectral cube Image window, go to 
>Overlay >Region of Interest 

•  In the ROI Tool, 
>Options >Band 
Threshold to ROI 

•  Select the D2300 band 
from the summary 
parameter file 

•  Type in min and max 
values of 0.04 and 
0.05, respectively 

•  Should get a result of 
108 pixels 

•  May want to refine 
threshold range to get 
fewer pixels 
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ROI-based Endmember Extraction (2/3) 

•  The ROI appears as red pixels in the 
displayed window 

•  In the ROI Tool, calculate the average of the 
pixels by clicking >Stats 

•  Right click within 
the Stats Results 
plot area to adjust 
Plot Parameters 
and view Plot Key 

•  Click and drag the 
Mean spectrum to 
the previously-
created spectral 
plot containing the 
pixel-based 
endmember 
spectrum 

ROI pixels 
also here 
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ROI-based Endmember Extraction (3/3) 

• A third method would be to define a polygon ROI… 
•  In the ROI Tool, select >ROI_Type >Polygon 
•  Create New Region and select Zoom as the 

active window 
•  Calculate statistics on the 

polygon-ROI as before 
•  The polygon ROI can be used 

alone or (e.g.) to spatially 
constrain the band threshold 
ROI:  >ROI Tool > Options  

            >Intersect  
      Regions 

right click 
to finalize 
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Example Endmember Spectra – D2300 

•  Three D2300 spectra were extracted using the methods discussed in 
previous slides: 1) 3x3 pixel average, 2) band threshold, and 3) polygon. 

•  In this scene, 
there are no 
huge 
differences 
between the 
spectra. 

•  In general, 
more pixels = 
less spectral 
noise. 
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Enhancing Spectral Features 

• There are two widely accepted ways to enhance spectral 
features to aid with interpretation: 
– Ratio to a spectrally neutral area in the same scene 
– Continuum removal 

• Benefit to using a ratio is that you may cancel out detector noise or 
spikes  

• However, if your denominator spectrum is not truly neutral  you may 
introduce unintended spectral shape, e.g., from: 
– Broad features from mafics like olivine or pyroxene 
– Spectral slope 
– VNIR variability from ferric oxide-related features 

• Continuum removal is not recommended over the entire CRISM 
wavelength range, either 
– Best results when focused on relatively narrow range bracketing the 

feature(s) of interest  
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Ratioing (1/2) 
•  Numerator: let’s use the D2300 spectrum with the least noise - 

the average from the green polygon ROI. 
•  Denominator: Create a similar-sized polygon in the nearby 

spectrally bland dark material and calculate its average 
spectrum Numerator 

Denominator 

•  From the ENVI main 
menu, go to >Basic 
Tools > Spectral Math 
•  Enter the 

expression: s1/s2 
•  Map the 

numerator (s1) 
and denominator 
(s2) to the 
Available Spectra 
List 

•  Output to New 
Window 
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Ratioing (2/2) 

Ratio-Enhanced 

Original D2300 Spectrum 

Numerator 

Denominator 
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Continuum Removal (1/2) 

•  In >Edit >Plot Parameters, subset the x-axis range to bracket the feature of 
interest 

•  Then choose Plot_Function > Continuum Removed as the display method 
•  You will likely have to rescale the y-axis in the continuum removed-plot 
 

1.427µm ? 
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Continuum Removal (2/2) 
Normal Continuum Removed 

2.291   2.390µm 

1.921µm 
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Spectral Libraries 

• Save spectra as ENVI spectral libraries (*.sli), 
or export as ASCII text file 
–  From a spectral plot window, >File >Save Plot As > 

Spectral Library 
– HINT: Line colors are not preserved; make sure you 

rename the spectra appropriately 

 

•  To retrieve a saved library or view 
a reference spectral library 
–  From the ENVI main menu, 

>Spectral > Spectral Libraries 
> Spectral Library Viewer 

–  Select *.sli file, or open new 
•  CRISM spectral library: http://

geo.pds.nasa.gov/missions/mro/
spectral_library.htm 
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Interpretation 

•  Compare the enhanced spectra to laboratory reference 
spectra to locate the best mineralogic match(es). 

•  For the D2300 endmember example, open a library 
containing phyllosilicate spectra and load candidate 
reference spectra to examine absorption band positions 
in detail… 

Diagnostic bands 
match best with 
nontronite. 1.427   1.941 

2.291  2.390  
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Interpretation Guidelines 

• Common sense rules apply to spectral interpretation: 
– All major absorption features in the spectrum of the proposed 

reference mineral should be present or otherwise accounted for 
– Relative strengths and shapes of spectral features of the proposed 

reference mineral should be replicated in the CRISM spectrum 

• Even a single CRISM pixel (~20m) is unlikely to comprise a 
single pure mineral, i.e.,  
– Spatial mixing is likely 
–  Intimate mixtures can also occur 
– Geochemically intermediate phases are also possible 

• So, simple explanations are usually best, but complexity 
happens.  It’s real geology, after all! 
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VISUALIZATION 
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3-D Rendering (1/3) 

• 3-D visualization can be helpful for understanding 
relationships between different units. 

• First, open the DDR cube (frt000094f6_07_de166l_ddr1.img) 
and load the Elevation band 
– Highest resolution MOLA gridded data is oversampled to match CRISM 

spatial scale; co-registration is good but interpolation in sparse areas 
can lead to feature mismatch 

– Note the approximate elevation range 
    under >Enhance >Interactive Stretching 

•  Load and stretch the band or RGB 
composite that you want to view in 3D 

•  From the Image window, go to >Tools 
>3D Surface View 
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3-D Rendering (2/3) 

•  In the 3D SurfaceView Input dialog 
–  Indicate Full DEM Resolution 
–  Type in min and max elevation values that 

bracket the actual range  
–  Indicate Full Image Resolution 

Initial 
3D view 
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3-D Rendering (3/3) 

•  Use mouse buttons to navigate, or 
use >Options >Surface Controls 

•  Perspective view here is looking 
south (5x vertical exaggeration) 

•  Note that the lowest point for the 
western crater (right side, arrows) is 
offset from the crater’s center due to 
sparseness of the interpolated MOLA 
tracks 

Colorized topography  
20m contours 

PHY browse product 

TAN browse product 
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Mosaicking (1/4) 

• Mosaicking multiple CRISM cubes together allows broader 
geographic context for inferred mineralogy. 
– Can mosaic map-projected spectral, summary parameter, or DDR cubes  

 
 
•  Retrieve from the PDS: 

–  FRT0000C875 
–  FRT00016BEE 

•  Run through photometric correction 
and map projection 
•  From the ENVI main menu, go to  
 >Map >Mosaicking >Georeferenced 
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Mosaicking (2/4) 

•  In the Mosaic dialog box, go to >Import 
>Import Files and Edit Properties 
– Select the two cubes you wish to mosaic 

•  For each file, 
indicate a Data 
Ignore Value of 
65535 and default 

    RGB bands at 
    230, 75, and 10. 
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Mosaicking (3/4) 

• To save, go to >File >Apply 
–  Indicate filename and 

 include a background  
 value of 65535. 

To adjust layering order or edit display 
properties, right click on filename here 
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Mosaicking (4/4) 

•  Load a mosaic just like 
any other file 

•  Go to >File >Edit ENVI 
Header >Edit Attributes 
to set Data Ignore 
Value (65535) and 
reapply band names if 
desired 

 
•  Difficult to avoid seams 

in mosaic due to 
varying atmospheric/
illumination/geometric 
conditions.  
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More Mosaic Results 

• Load the mosaic file and generate the D2300 summary 
parameter: 
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What is an MTRDR? 

1)  An image cube of I/F from a TRR3 for a targeted observation’s central 
swath, with additional processing: 
-  The best current correction for atmospheric gases 
-  Lambertian photometric correction 
-  First-order empirical normalization of atmospheric opacity to the nearest-nadir 

geometry 
-  Residual cross-track optical distortions (“spectral smile”) fitted and normalized 
-  VNIR data reprojected to IR data in sensor space 
-  “Bad bands” removed 
-  Map projected to a global standard (equirectangular, rolling center latitude of 

projection) 
2)  An image cube of spectral indices (“summary products”) derived from 

these corrected, normalized data 
3)  An image cube of map-projected geometric information from the DDRs 

•  Our current, best, “whole image” correction to what an idealized 
version of CRISM would see if it only pointed an nadir 
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MTRDR Nomenclature 

•  FRT = Class Type  
–  FRT (Full Resolution Targeted Observation) 
–  HRL (Half Resolution Long Targeted Observation) 
–  HRS (Half Resolution Short Targeted Observation) 

•  00003E12 = 8-digit hexadecimal Observation ID 
•  07 = Hex counter for image within observation  
•  IF166 = Processing, internal command macro 

used  
–  IFnnn – I/F / Macro# 
–  SUnnn – Summary products / Macro# 
–  DEnnn – Derived data / Macro# 

•  J = Sensor ID 
–  J for joined (for IF and SU) 
–  L for IR (for DE) 

•  MTR3 = MTRDR, calibration version = 3 
•  IMG = file extension 

–  IMG for binary image data  
–  LBL for detached ASCII PDS label 

FRT00003E12_07_IF166J_MTR3.IMG  
The file name describes the type of data, 
an overview of the processing, and gives 
the unique ID and counter 
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We’re Also Delivering a non-Map 
Projected Version of the Corrected Data  

Multiband image of corrected I/F; 
VNIR re-projected to IR; “bad bands” 
STILL PRESENT 

Detached PDS label describing the 
source files, corrections performed 

Scene I/F, unitless 
TER = Targeted Empirically-corrected Data Record 
•  FRT = Class Type  

–  FRT (Full Resolution Targeted Observation) 
–  HRL (Half Resolution Long Targeted) 
–  HRS (Half Resolution Short Targeted) 

•  00003E12 = 8-digit hexadecimal Observation ID 
•  07 = Hex counter within observation  
•  IF166 = Processing, internal macro used  

–  IFnnn – I/F / Macro# 
•  J = Sensor ID 

–  J for joined 
•  TER3 = TER, calibration version = 3 
•  IMG = file extension 

–  IMG for binary image data  
–  LBL for detached ASCII PDS label 

FRT00003E12_07_IF166J_TER3.IMG  
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Each Type of I/F File is Accompanied by a 
Table of Wavelengths Present 

ASCII table of 
image band 
numbers and 
wavelengths 

Detached PDS label 
describing the table 

•  FRT = Class Type  
–  FRT (Full Resolution Targeted Observation) 
–  HRL (Half Resolution Long Targeted) 
–  HRS (Half Resolution Short Targeted) 

•  00003E12 = 8-digit hexadecimal Observation ID 
•  07 = Hex counter within observation  
•  IF166 = Processing, internal macro used  

–  IFnnn – I/F / Macro# 
•  J = Sensor ID 

–  J for joined 
•  TER3 = Product type and calibration version 

–  TER, calibration version = 3 
–  MTR, calibration version = 3 

•  TAB= file extension 
–  TAB for table of wavelengths 
–  LBL for detached ASCII PDS label 

FRT00003E12_07_WV166J_TER3.TAB 
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Custom Composites 

• Custom RGB composites 
and browse products can 
take advantage the joined 
nature of the MTRDR 
summary parameter cube. 

 
• Example at right  
 shows ferric,  
 ferrous, and  
 clay variability. 
• MANY color units 
 to follow-up on!! 

R: BD530  G: OLINDEX2  B:D2300 
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QUESTIONS? 

Please also visit the PDS forum: http://geoweb.rsl.wustl.edu/
community/index.php?/ 

forum/20-mrocrism-data-users-workshop-2012/ 
 


